Create topic New topics

Forum

Chatter away, friends!  

Problem with Amazon ID tracking dropdown menu

 
vikksimmons
Posts: 71
Message
on 06/11/2011

I have Amazon affiliate and I set up a Wizzley tracking ID in Amazon last night. 

I cannot get the dropdown menu to work. The default id works fine. I've tried in Chrome, Firefox, IE 8 and it won't work. 
I went to the Amazon help and sent an email but I won't hear anything for a day or two. I tried the forum support group. I received this answer but i don't know if it will help:

The tracking-ID dropdown seems to be working correctly in IE9. Chrome is my default browser, but once in a while I have problems with a form or popup that works if I switch to Firefox or IE.

You might try adding amazon.com to your list of popup exceptions and/or other security browser settings.

I went into Chrome, IE 8 and the computer security but I can't find what he's talking about. I've tried Google searchign but I'm not getting anywhere. I've been fooling wiht this for hours. Any ideas? 

lou16
Posts: 120
Message
on 06/11/2011

It's been working okay for me in Chrome, but have you tried unchecking the box for combined reports before trying to change it?   I tried this once when it wasn't working (the only time in years that I've encountered such a problem I should add) and it seemed to work..........that might have been a coincidence for me, but it's worth a try.

You've encountered the one problem I have with Amazon - when something goes wrong you can never seem to get useful help :(


lou16
Posts: 120
Message
on 06/11/2011

Sorry just re-read your question and you want to know how to do what the person suggested.

Go to control panel, click on system and security then click on Windows firewall

On the left hand side there are a number of different options - click on the allow a program or feature through windows firewall.

Now I should add I've never had to do this so I'm not sure if I wouldn't wait for an email back from Amazon support before proceeding with it.

I hope that helps.


puzzlemaker
Posts: 16
Message
on 06/11/2011

I don't know if I can help or not, but are you talking about at Amazon Assoc. page on the left hand side of the screen at the top? It says "signed in as" and your ID listed, then under that is says "Tracking ID" with a drop-down menu? I created one recently and it is working OK. Not for Wizzley, but for my blog.

Also, I found the phone number for Amazon Affiliates one day while digging around. I keep it handy and have used it a few times when I couldn't figure things out.

Here it is for anyone who might need to call: 1-800-372-8066 Amazon Associates Help

WebWriter
Posts: 87
Message
on 06/12/2011

 

puzzlemaker: 11. Jun 2011, 20:02

I don't know if I can help or not, but are you talking about at Amazon Assoc. page on the left hand side of the screen at the top? It says "signed in as" and your ID listed, then under that is says "Tracking ID" with a drop-down menu? I created one recently and it is working OK. Not for Wizzley, but for my blog.

Also, I found the phone number for Amazon Affiliates one day while digging around. I keep it handy and have used it a few times when I couldn't figure things out.

Here it is for anyone who might need to call: 1-800-372-8066 Amazon Associates Help

It says this in the Wizzle Help FAQ section:

The current terms of the eBay Partner Network don't allow this as a revenue source for Wizzley.com authors. We hope to offer this possibility in the future. 


puzzlemaker
Posts: 16
Message
on 06/12/2011

Wait. We are talking about Amazon and not ebay right?

Maybe Vikk has it sorted out by now.

vikksimmons
Posts: 71
Message
on 06/12/2011

No, it's not sorted out but I did find a work-around. If I go to my laptop I can at least get the new tracking number to appear but I can't use the stripe at the top of the page or the widgets. I have to stay in Affiliate Central, search there, and then click on the image and go to the affiliate link wizard there. In Central I can get the text link wihch is what I need. 

But that means using two computers. And I still can't get the dropdown to work on the stripe to get the additional tracking numbers or get the widgets to work.

I will call Amazon tomorrow and see what they tell me--unless they're avaialble today. Maybe I'll try. Thank you so much for the phone number. 

eBay? There's affiliate numbers for eBay? :) 

I wasted a good 4-5 hours with this and my Wiz page took about 8-10 hours yesterday when it should have only taken a few hours. Sigh. Thanks! 

I will keep trying to work this out. 


vikksimmons
Posts: 71
Message
on 06/12/2011

 

WebWriter: 12. Jun 2011, 01:27

 

puzzlemaker: 11. Jun 2011, 20:02

I don't know if I can help or not, but are you talking about at Amazon Assoc. page on the left hand side of the screen at the top? It says "signed in as" and your ID listed, then under that is says "Tracking ID" with a drop-down menu? I created one recently and it is working OK. Not for Wizzley, but for my blog.

Also, I found the phone number for Amazon Affiliates one day while digging around. I keep it handy and have used it a few times when I couldn't figure things out.

Here it is for anyone who might need to call: 1-800-372-8066 Amazon Associates Help

It says this in the Wizzle Help FAQ section:

The current terms of the eBay Partner Network don't allow this as a revenue source for Wizzley.com authors. We hope to offer this possibility in the future. 

No, I'm talking about Amazon. :) 

I created an Amazon tracking number for my account and it shows up with the others fine in the drop down on the left inside the account. What happens is that when I'm in Amazon and try using the stripe at the top of the page which is what I normally do, the drop down box doesn't work. I can only get the default original tracking number--which I can use but I really wanted to switch now to the new one for Wizzley before I get too far along. 

Also, I can't get the other tracking numbers to show up in the wdige using the stripe. 

And on my desktop I cannot get any other tracking ID except for the default one in Amazon central through my account. 

The only way I can access the tracking number to work in any dropdown with products is on my laptop and inside Amazon Central. Even on the laptop I can't get the stripe to work. So It's not apparently related to things going on with my computer--although I did do everything I could to clear the cache and all that mess. 

So yes, I'm still having trouble but I did get a workaround. 

 


puzzlemaker
Posts: 16
Message
on 06/12/2011

Vikk,

I created one for Wizzley last night to see what happened. It worked and I can choose the ID with the site stripe.

If I use the site stripe and click on "Link to this page," I get the pop up box with "Get HTML Code For This Link" at the top. It is letting me choose any of my Tracking ID's there through the drop down menu.

So sounds like there is a glitch with Amazon and your new ID. I hope they can get it fixed.

chefkeem
Admin
Posts: 3394
Message
on 06/12/2011

Just to be clear on the entire process when creating an Amazon aff link...

I sign into my Amazon affiliate account. It will say on the top left: signed in as "chefkecom-20"

I pick my desired tracking ID from the drop down menu. This will display my desired tracking ID in the window of the drop down menu.

It will NOT change my sing-in ID on top of the left sida bar. Even with a different tracking ID, I will still stay signed in as "chefkecom-20".

Now I pick a product link and look at the code. It should show the specific tracking ID I had picked from the drop down menu.

While I'm on that code page, I can still change the tracking ID from the drop down menu. The page will reload and display my new tracking ID.

If any of this does NOT work as described, then there might be a different problem for which I can't offer any help, unfortunately.


Achim "Chef Keem" Thiemermann is the co-founder of a pretty cool new platform called...um...er...oh, yeah - Wizzley.com.
vikksimmons
Posts: 71
Message
on 06/12/2011

Yep, Chefkeem, that's how it works. And nope, that's how it doesn't. :) The dropdown works in the account on the upper left where all the tracking numbers are located but I can't get it to work when I'm on the page and using the stripe at the top or when I am trying to use the banner/link area to create code. It just won't click. I can only get the default id. 

At least on the laptop I have found a workaround but that doesn't even work when I'm on my desktop. It's really weird. I'm going to have to use the phone number and call. I'm just putting it off because I know it will be frustrating. :) And I have to make sure I won't be interrupted with caregiving or dog owning issues. :) 

Thanks! 


lakeerieartists
Posts: 769
Message
on 06/12/2011

Vikk, until you get it fixed on Amazon, you can just substitute the id you want in your code for whichever place you are using it on.  Also, if you are using Wizzley modules, it will use what ever code you have put into the settings.

Sounds like an Amazon glitch to me.  Should work in any browser.


Paula Atwell (aka lakeerieartists) is the owner of an online art gallery, Lake Erie Artists Gallery and a freelance writer
bev-owens
Posts: 91
Message
on 06/12/2011

I paid close attention today when I was doing the very thing that you are trying to do, Vikk. I was writing a blog post and was using the Stripe at the top of the page.

The pop-up that came up for me showed two drop downs:

  • the name I was logged in as
  • the tracking ID that I wanted to use

From what I am gathering in your explanation...that second one is not working for you...right? That does seem to be some sort of "glitch" with Amazon and your set-up. I think the Amazon people could probably help you get it resolved.

As Paula suggested...the easiest way to get around it is to just change your tracking ID in your code until Amazon can help you figure it out. BTW there are 2 places in that code that show your ID so make sure you change both of them.

vikksimmons
Posts: 71
Message
on 06/12/2011

I do the text only. There's two places? I thought there was only one. Good thing you mentioned. I'll have ot look next time. 

 

Thanks, Paula, I am working around it until I call and using the module. I was working on a test page for tracking which is why it was so annoying yesterday. :) 

@Bev, yep, when I go to the strip and get into getting the code it doesn't really show the dropdown feature. It shows the default tracking but nothing happens when you click and it's all pale and wihtout muchof a border.For some reason that feature went out. I had been using it all week so it was a rather sudden thing. I do think it must be on Amazon's side.

Naturally their email said, 'oh well, I did it and it worked for me. Please send me the link to the page it wasn't working on. Dummy. I siad it wasn't working on ANY pages.' Sigh. :) I will definitely call. 


Loading ...
Error!